北京用友北京用友

您所在的位置:首页 -> 常见问题 -> 用友T1常见问题
批发零售版本如何升级
浏览:2142次 评论:0条 发表日期:2019-04-02 21:19:16作者:
Tags:
案例背景】
软件更新日新月异,多年前购买的版本已不能满足现在运行需求,为获取更好的服务,使用更新功能,需要将软件升级到最新版本中。但是软件升级并不是直接恢复数据升级的,必须一个版本一个版本升级。
 
【升级方法】
一、批发零售版本介绍
商贸通10.1,商贸通10.2,商贸通新锐版本11.0,商贸宝批发零售版11.0,商贸宝批发零售版11.1,商贸宝批发零售版11.5,商贸宝批发零售版12.0,商贸宝批发零售版12.1。
 
二、版本升级
由于版本过渡比较大,表结构之间的字段变化比较大,在数据升级时,需要数据从低版本一级级升级到高版本,否则升级后的数据可能会出现问题。在对应的文件夹中是各个版本的升级脚本,其中“金盘脚本”是安装软件时,软件没有安装过补丁的SQL脚本,“最新补丁脚本”是安装最新补丁后的SQL补丁脚本。下面举例介绍升级步骤:
如果使用的版本是商贸通新锐版本11.0,需要升级到批发零售12.1版本,版本升级如下:1)执行商贸通新锐版本11.0最新补丁脚本;2)执行商贸宝批发零售版11.0金盘脚本;3)执行商贸宝批发零售版11.0最新补丁脚本;4)执行商贸宝批发零售版11.1金盘脚本;5)执行商贸宝批发零售版11.1最新补丁脚本;6)执行商贸宝批发零售版11.5金盘脚本;7)执行商贸宝批发零售版11.5最新补丁脚本;8)执行商贸宝批发零售版12.0金盘脚本;9)执行商贸宝批发零售版12.0最新补丁脚本;10)安装批发零售版本12.1安装程序,数据直接升级即可。
三、升级时,选择对应版本文件夹中的脚本,在查询分析器中执行,如图:

 
四、执行后会报一些错误,属于正常现象,不用处理,如图:

【升级总结】
上边举例中,需要执行脚本9次,第10次时,安装批发零售版12.1程序,点升级账套,会提示“数据库版本低,请升级”,此时,点确定即可升级。
注:如果数据版本是10.1或者10.2版本,只要执行“商贸通版本10.2”文件夹中的脚本,然后在依次执行后续文件夹中的升级脚本即可。如:数据版本是商贸通10.1数据,只需要执行“商贸通版本10.2”文件夹中的脚本,然后在从“商贸通新锐版本”文件夹中的脚本依次执行。
通过上边的例子,可以看出,数据升级到高版本时,先执行本版本的最新补丁脚本,然后在依次执行后边版本的金盘脚本和最新补丁脚本。



上一篇T1-如何设置每页打印固定行数
下一篇用友畅捷通T+往来账龄余额与科目..

最新文章

用友U8软件取消供应链模块
登录软件提示:无效图片481
U8账套反结账怎么操作
用友U8软件填制凭证提示:运行时错误35601,未发现元
读取数据源出现未知错误:remoting信道异常
用友U8 在正常记提折旧后,进入折旧分配表界面时,突
最新图文教程

北京用友远程维护收

2021年国庆长假如何

资产负债表与余额表

用友U8软件填制凭证

用友软件中了[helpba

T+13.0现存量查询不

T+13.0现存量查询无

解决“连接U8数据库

热门文章

[09-15]
[10-08]
[10-26]
[10-15]
[05-13]
[09-18]

推荐文章

相关文章

在线咨询
售后支持
  • 业务电话:010-84986180
  • 13720089039
  • 夜间值班:18910108696
  • 北京会计QQ群:6388368